Connectivity issues on Deskpro Cloud
Incident Report for Deskpro
Resolved
This issue has been resolved.
Posted Apr 02, 2020 - 09:27 BST
Investigating
We are investigating connectivity issues.
Posted Apr 02, 2020 - 09:24 BST